Results 1 to 3 of 3

Threaded View

  1. #1
    Join Date
    Jan 2010
    Location
    Cornwall
    Posts
    54
    Images
    12

    Default Pentax kit lenses a liitle below par

    Hi, im new to the forum and own a K7 pentax, problem being i am noticing some very heavy blooming effect when taking basic test shots, i have not had the camera in the field yet, but i am concerned about the quality of the lens.

    i'ts noticable on parts of the image where it goes from focus to dof and makes it look like a steamy room, or an old playboy mag warming effect.

    I cant believe the lense is that poor, although i do appreciate that, the lense is a price saving part of the kit.

    however you do not expect it to this degree on a 900.00 camera

    anybody else having the same issue?

    is it something that can be sorted with firmware (ie, lense correction) or is a new lense needed.?

    Other then that... i am very impressed with the camera, and the build quality is unbeatable in my opinion.

    ive owned the k100 super, the k10d, prior to this camera and its a noticable improvement on focus time,and continuous shots,but image quality isnt that far ahead, sure the size is larger being 14.5mb but theres no noticable changes to the images.

    thanks

    shaun2k
    Last edited by shaun2k; 21-01-10 at 07:19 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •