Results 1 to 8 of 8

Hybrid View

  1. #1

    Default 1000D Constant blue light??

    Hi

    I'm new here but hoping someone may be able to advise.

    Last Saturday I was caught in a lot of rain whilst out with my camera (I have had it for nearly 2 years now so no warranty) and unfortunately the camera got caught too!

    I dried the camera out but now I have a constant blue light where the WB button is, the only way to make it go is to take the battery out. Also the camera no longer turns on!

    Does anyone know if this is fixable at all or am I looking at getting a new camera?

    Regards

    Michelle

  2. #2
    Join Date
    Jan 2010
    Location
    NW England
    Posts
    1,148
    Images
    11

    Default

    i am afraid it may be back to canon so you would have to see what they would charge. have you tried a full reset

  3. #3

    Default

    Quote Originally Posted by wave View Post
    i am afraid it may be back to canon so you would have to see what they would charge. have you tried a full reset
    Thank you for replying wave.

    I haven't tried a full reset, how do I do that?

  4. #4
    Join Date
    Jan 2010
    Location
    NW England
    Posts
    1,148
    Images
    11

    Default

    it will be in the menus or custom functions look revert to factory settings

  5. #5

    Default

    Quote Originally Posted by wave View Post
    it will be in the menus or custom functions look revert to factory settings
    I can't turn it on though :-/

  6. #6
    Join Date
    Jan 2010
    Location
    NW England
    Posts
    1,148
    Images
    11

    Default

    sorry to say this but it doesn't sound good take the lens off and make sure its completely dry take out the battery and leave everything open for a couple of days then try again

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •