Results 1 to 9 of 9
  1. #1

    Default NIKON D70 no pwer.

    All power to the camera is dead. Have tried another battery both measured 7.1 volt. Have tried both ways of resetting but no luck. No damage to the battery or the camera. No sign or life at all. Help !

  2. #2
    Join Date
    May 2010
    Location
    scotland
    Posts
    995
    Images
    43

    Default

    H welcome to the forum. Try cleaning the contacts in the battery compartment with a rocket blower or a can of compressed air. good luck... Graham

  3. #3

    Default

    Thanks.
    All contacts are clean...

  4. #4
    Join Date
    May 2010
    Location
    scotland
    Posts
    995
    Images
    43

    Default

    Sounds like it needs to go back to Nikon for a repair

  5. #5
    Join Date
    Jun 2012
    Location
    Manchester
    Posts
    166
    Images
    144

    Default

    Just an afterthought have you bought any non Nikon batteries lately. These are common causes of fried cameras.

  6. #6

    Default

    Thanks. Hope your wrong ��

  7. #7

    Default

    No. Just the original one. Thanks.

  8. #8
    Join Date
    May 2010
    Location
    scotland
    Posts
    995
    Images
    43

    Default

    With a memory card inserted, does the green access light blink continuously

  9. #9

    Default d70

    Quote Originally Posted by graham_c View Post
    With a memory card inserted, does the green access light blink continuously
    No lights at all. Definitely a power connection problem.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •