Results 1 to 2 of 2

Hybrid View

  1. #1

    Default Sony Cybershot T9... having problems

    Hi all,

    I have a DSC-T9 which has seen better days... I am getting another camera but would like to keep this for general pics when out and about as it's small to just take in handbag/pocket.

    Problems are... the video which used to work quite well, still records ok and looks fine on the screen whilst actually recording. When I load it on to computer and play it, it's awful quality... i'm not camera literate so difficult to describe but you can't see the same detail, its juddery and it's almost like the pixels might not be working properly. I think it might be shooting in another mode or different quality, something is different when I shoot and play back on the actual camera. The playback screen is very small compared to the amount of scrren that is used to look at photos. . I am not sure why this has happened suddenly and the photos are fine. I am probably not making much sense here, sorry.

    A problem which cant be fixed is the screen is damaged (pics are fine tho) and covering quite a significant amount so accessing all menus is difficult as can't see some of the bottom options! I really like this camera as a backup tho and I have quite good underwater housing which was 250 so really don't want to throw it away as it's ok for diving photos. I don't want another the same tho as I will already be shelling out for a better camera for other types of photography.

    Cheers

  2. #2

    Default

    Well I have been randomly pressing buttons yet again which I cannot even see what they are and think it may have been fixed a little bit but not quite the same. Hopefully no other setting changed. At least looks like it was not broken.

    I guess there is no point in replacing screen as will cost quite a bit

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •