Results 1 to 3 of 3

Thread: Canon 500D

Hybrid View

  1. #1
    Join Date
    Jul 2010
    Location
    UK
    Posts
    1

    Default Canon 500D

    I recently purchased the 500D. On my first couple of outings I found when I returned home, the pictures I thought I had taken had not recorded onto the camera. I initially thought that perhaps I had done something inadvertently. However, I have now had the camera for 3 months and I am finding that most of my pictures are not registering on the camera. On the other hand. some are. I tend to use the viewfinder and not the LCD monitor.

    Its a strange one and something I haven't come across before. Does anyone have any ideas, please?

  2. #2

    Default

    hi breeze

    when you say registering to cam do you mean they are not saving to your memory card
    as i own a 500D my self m8 and never come across this and ive took a lot of photos since i brought it
    have you tryed different memory card sounds like they might be a prob with that if its not saving them once you have taken them
    if that dont help id take it back to were you brought it from

    hope you can sort your problem out m8

    russ

  3. #3
    Join Date
    Dec 2010
    Location
    Irvine, Scotland, UK
    Posts
    1

    Smile Canon 500D

    Hi Breeze,
    Your memory card problem seems to be a strange one to say the least, but have you tried re-formatting your memory card? Try that and if still no success, try another card. If you still have the problem then I would return the camera to have it checked out. The Canon 500D is certainly a great camera. I hope that you get it sorted out soon!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •