View Full Version : Canon 400D - works inside BUT NOT OUTSIDE ??

25-06-12, 01:09 PM
My Camera (Canon 400D) will work fine indoors but the moment you take it out into daylight it comes up the error generic error code of 'error 99'.. Turn it off and on again take it indoors and it works fine, take it outdoors and it comes with the error code - I've tried this again and again - you wouldn't believe how many shots of the porch I have (I've been standing in the front door; turn left and take photo indoors - its fine.... Turn right and take photo of garden, error 99 "!!!")
Has anyone else had this problem ?? How did you rectify it. I've tried cleaning the gold lense sensors, but that hasn't worked.

25-06-12, 02:23 PM
Welcome to the forum.
Not being a canon user I don't know the error code, but I would try this
1 take out the battery and reinsert it
2 gently clean the lens contacts
3 try using a different lens
4 make sure you have the latest firmware installed in the camera.
5 Find the reset button and press it. Good luck ... Graham

25-06-12, 02:47 PM
Hi Graham,
Thanks for reply - I've cleaned the lens contacts and even swapped batteries. Not thought about swapping lenses so will give it a go. Have no idea what firmware is (I'm a bit of a novice), but my camera doesn't get linked up with anything else and it only has its normal lenses (no others have been used on it). 'Re-set button', this sounds like a good idea (I thought taking battery out and putting it back in re-set it, so I'll see if there is a re-set button on it; but not sure if there is).
Thank you for your ideas, they're very much appreciated. I'll definitely give them a try.
Victoria x

26-06-12, 07:49 AM
this seems to be a catch all error but it does seem to be associated with the lens connection so cleaning them will help looking at the web there are various work arounds that people use all have been said above except for the one that i found interesting. if the battery was charged over night then the problem didnt occur for a period of time so it may also be the sign of an ageing battery. good luck

28-06-12, 10:11 AM
Our battery is a couple of years old, its not fully charged either, so I'll definitely give this a go !!
If a fully charged battery still throws up the generic error code, I'll buy a new one and see if that works.
Thank You for your help
Victoria x